• Let op: Dit is het archief van het Provider Forum. De berichten die je hier ziet zijn gedateerd en er kan niet meer op worden gereageerd.

Wifispots op Linux Mint

  • Onderwerp starter Theancientone
  • Startdatum
Status
Niet open voor verdere reacties.
T

Theancientone

Hallo Iedereen,

Ik heb een vraag! Sinds begin vorige maand zijn er bij mij in de buurt Ziggo wifispots aanwezig. Ik kan hier gebruik van maken maar het lijkt niet goed te werken.

Onder een windows/macOS omgeving werkt het prima en zo ook met Android. Echter ben ik geen gebruiker van deze systemen. Ik zou graag gebruik maken van dit nieuwe product onder Linux Mint. Helaas lijkt dit niet te werken :(.

Ik heb alle instellingen goed staan zoals vermeld onder windows en android maar hij blijft om een CA Certificaat vragen waardoor ik niet in kan loggen op de ziggo wifi spots.

Is hier toevallig iemand die weet hoe ik hier mee om kan gaan?

Alvast bedankt voor de hulp!

The Ancient One
 
maar hij blijft om een CA Certificaat vragen waardoor ik niet in kan loggen op de ziggo wifi spots.

Dan zul je ergens moeten instellen om geen certificaat te gebruiken, of te zorgen dat dat certificaat op je computer komt.

Ziggo gebruikt het certificaat van https://www.comodo.com/, maar op hun website kan ik nergens een download lokatie van hun basis certificaat vinden.
Normaal heeft je OS dit al voor je geïnstalleerd. Op de mac staat het en je kunt het ook exporteren in een ".cer" formaat. Daarna moet het door jouw Linux systeem weer in te lezen zijn. (Ik heb hier echter geen ervaring mee)
 
Dank je wel voor je reactie. Echter word er in de instellingen aangegeven dat er geen certificaat gebruikt hoeft te worden. Dus er zou geen reden moeten zijn om om het certificaat te vragen.

We gaan wel even verder zoeken. Wellicht is er nog iemand van jullie die weten hoe het moet of werkt.
 
UPDATE: Ik heb een comodo certificaat gevonden, ik ga dit vanavond uit testen.
 
Mischien dat je via hier een oplossing vindt.

Dank je wel, ik had de post van vraag.ubuntu-nl.org al gezien. Ik ga dit zeker testen en als het lukt dan laat ik het hier weten, mochten er nog meer mensen zijn dan kunnen ze dit nalezen.
 
UPDATE:

Helaas hebben geen van beide oplossingen gewerkt. Ik ga nog verder experimenteren met instellingen om te zien of iets werkt.

Ik hou jullie op de hoogte!
 
Met deze instelling werkt het bij mij op (black) Ubuntu :

vNizjURWhAHj1zfDjboI.png


En met deze ook :rolleyes:

f3DgNUOZhDcrjhscdGFp.png
 
Laatst bewerkt door een moderator:
En hier nog een gedeelte uit de syslog :

Code:
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) starting connection 'Auto Ziggo'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> (wlan0): device state change: 3 -> 4 (reason 0)
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0/wireless): access point 'Auto Ziggo' has security, but secrets are required.
Sep  5 17:13:58 janvm NetworkManager[740]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> (wlan0): device state change: 6 -> 4 (reason 0)
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Sep  5 17:13:58 janvm NetworkManager[740]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0/wireless): connection 'Auto Ziggo' has security, and secrets exist.  No new secrets needed.
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'ssid' value 'Ziggo'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'scan_ssid' value '1'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'key_mgmt' value 'WPA-EAP'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'password' value '<omitted>'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'eap' value 'PEAP'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'fragment_size' value '1300'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'phase2' value 'auth=MSCHAPV2'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: added 'identity' value '99999999'
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Sep  5 17:13:58 janvm NetworkManager[740]: <info> Config: set interface ap_scan to 1
Sep  5 17:13:58 janvm NetworkManager[740]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Sep  5 17:14:08 janvm wpa_supplicant[991]: Trying to associate with ea:40:f2:fe:12:72 (SSID='Ziggo' freq=2437 MHz)
Sep  5 17:14:08 janvm NetworkManager[740]: <info> (wlan0): supplicant connection state:  scanning -> associating
Sep  5 17:14:14 janvm kernel: [ 1774.694528] wlan0: authenticate with ea:40:f2:fe:12:72 (try 1)
Sep  5 17:14:14 janvm kernel: [ 1774.696844] wlan0: authenticated
Sep  5 17:14:14 janvm kernel: [ 1774.696862] wlan0: associate with ea:40:f2:fe:12:72 (try 1)
Sep  5 17:14:14 janvm kernel: [ 1774.706991] wlan0: RX AssocResp from ea:40:f2:fe:12:72 (capab=0x411 status=0 aid=6)
Sep  5 17:14:14 janvm kernel: [ 1774.706993] wlan0: associated
Sep  5 17:14:16 janvm NetworkManager[740]: <info> (wlan0): supplicant connection state:  associating -> associated
Sep  5 17:14:16 janvm wpa_supplicant[991]: Associated with ea:40:f2:fe:12:72
Sep  5 17:14:16 janvm wpa_supplicant[991]: CTRL-EVENT-EAP-STARTED EAP authentication started
Sep  5 17:14:16 janvm wpa_supplicant[991]: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
Sep  5 17:14:16 janvm wpa_supplicant[991]: EAP-MSCHAPV2: Authentication succeeded
Sep  5 17:14:16 janvm wpa_supplicant[991]: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
Sep  5 17:14:16 janvm NetworkManager[740]: <info> (wlan0): supplicant connection state:  associated -> 4-way handshake
Sep  5 17:14:16 janvm NetworkManager[740]: <info> (wlan0): supplicant connection state:  4-way handshake -> group handshake
Sep  5 17:14:16 janvm wpa_supplicant[991]: WPA: Key negotiation completed with ea:40:f2:fe:12:72 [PTK=CCMP GTK=CCMP]
Sep  5 17:14:16 janvm NetworkManager[740]: <info> (wlan0): supplicant connection state:  group handshake -> completed
Sep  5 17:14:16 janvm NetworkManager[740]: <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'Ziggo'.
Sep  5 17:14:16 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
Sep  5 17:14:16 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
Sep  5 17:14:16 janvm NetworkManager[740]: <info> (wlan0): device state change: 5 -> 7 (reason 0)
Sep  5 17:14:16 janvm NetworkManager[740]: <info> Activation (wlan0) Beginning DHCPv4 transaction (timeout in 45 seconds)
Sep  5 17:14:16 janvm wpa_supplicant[991]: CTRL-EVENT-CONNECTED - Connection to ea:40:f2:fe:12:72 completed (reauth) [id=0 id_str=]
Sep  5 17:14:16 janvm NetworkManager[740]: <info> dhclient started with pid 2839
Sep  5 17:14:16 janvm NetworkManager[740]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
Sep  5 17:14:16 janvm dhclient: Internet Systems Consortium DHCP Client V3.1.3
Sep  5 17:14:16 janvm dhclient: Copyright 2004-2009 Internet Systems Consortium.
Sep  5 17:14:16 janvm dhclient: All rights reserved.
Sep  5 17:14:16 janvm dhclient: For info, please visit [URL]https://www.isc.org/software/dhcp/[/URL]
Sep  5 17:14:16 janvm dhclient: 
Sep  5 17:14:16 janvm NetworkManager[740]: <info> (wlan0): DHCPv4 state changed nbi -> preinit
Sep  5 17:14:16 janvm dhclient: Listening on LPF/wlan0/64:70:02:25:77:e3
Sep  5 17:14:16 janvm dhclient: Sending on   LPF/wlan0/64:70:02:25:77:e3
Sep  5 17:14:16 janvm dhclient: Sending on   Socket/fallback
Sep  5 17:14:16 janvm dhclient: DHCPREQUEST of 10.145.0.9 on wlan0 to 255.255.255.255 port 67
Sep  5 17:14:19 janvm dhclient: DHCPREQUEST of 10.145.0.9 on wlan0 to 255.255.255.255 port 67
Sep  5 17:14:19 janvm dhclient: DHCPACK of 10.145.0.9 from 10.145.0.1
Sep  5 17:14:19 janvm dhclient: bound to 10.145.0.9 -- renewal in 1503 seconds.
 
Laatst bewerkt door een moderator:
Beste Mesa57,

Ik heb exact dezelfde instellingen als in de afbeelding waarin mschapv2 in staat! Echter, vraagt Linux Mint (ubuntu gebaseerd) altijd om een CA certificaat als het wil inloggen op het ziggo netwerk :S.

Ik heb overigens al een certificaat geprobeerd van Comodo zoals eerder in deze post vermeld door Briolet maar dit werkte ook niet :(.

In ieder geval dank voor de hulp en ik ga even die instellingen proberen te wijzigen zodat ik wel verbinding krijg.
 
Status
Niet open voor verdere reacties.
Terug
Bovenaan