Terayon modem, interne serial poort !

Status
Niet open voor verdere reacties.
N

n0m0r3

Dames en Heren,

Wel eens de Chello Terayon modem open geschroeft ?
Hier zit namelijk een interne console (db9) aansluiting op het "moederbord", kreeg er tot nu to alleen maar abra-ca-dabra uit.
iemand nog ideas of tips ?

n0m0r3

PS zal nog ff zoeken naar een foto !
 

sylvester(rr)

Quality Member
Berichten
9.691
Wel eens de Chello Terayon modem open geschroeft ?
Jah...
nosmile.gif
(niet doorlullen he
wink.gif
hypocrite.gif
)
Het is zo'n...ehh...vaag ding...
nosmile.gif
 

TMB!

Forum Gebruiker
Berichten
1.020
Internet
  1. Ziggo
Digitale TV
  1. Ziggo
8)
Wat heb je dan geprobeerd? Een RS232 monitor aan te sluiten?
Of direct aan de pc? Met welke instellingen? Baudrate, # databits, # prioriteitsbits, even/odd???
Of heb je maar 1 ding geprobeerd?

Meestal staan zulke dingen op 9600,7,1,N Dat al geprobeerd?
8)
 
Topicstarter
Topicstarter
N

n0m0r3

Ik heb van alles geprobeerd, kreeg op een gegeven moment wel rare sh*t voorbij.

instellingen stonden toen op 9600,8,n,1

Als ik soon tijd heb zal ik wel een aantal tests doen en fotos posten !

n0m0r3
 

TMB!

Forum Gebruiker
Berichten
1.020
Internet
  1. Ziggo
Digitale TV
  1. Ziggo
8)
Ok, als het er interessant genoeg uitziet zal ik um ook openschroeven ;D
8)
 
R

Remboooo

is het niet zo dat als je op 8,1 rare schijt krijgt dat het dan op 7,1 er wel es heel leesbaar uit zou kunnen zien?
bye.gif
 
G

gastje

Hi everyone.

I found the way to connect to the TeraPro cablemodem using a 3wire
serial connexion.

Here's how to proceed...

1 - Open your modem, place it so the coax connector points towards
you.
You'll see a ten pin connector near the status LED... here's the
pin-out:

1 2 3 4 5
X X X X X
X X X X X
6 7 8 9 10

1 : TX : Data sent to your PC/interface @ 9600,8,N,1
2 : +5V DC (used for CTS/DSR I guess)
3 : GND
4 : unknown
5 : +5V DC (used for CTS/DSR I guess)
6 : N/A
7 : RX : Data sent to the modem
8 : +5V DC (used for CTS/DSR I guess)
9 : N/A

Please note that only pins 1, 3 and 7 are important.

2 - Unfortunately, the modem uses +5V TTL signalling, so it's
impossible to connect it directly to your PC...you'll need a 5V/12
converter. It's really easy to build it with a Maxim MAX232 IC and a
couple of capacitors.(there are a lot of schematics available on the
net or you can just use Maxim's datasheet)

3 - Connect your modem to your PC :

PC <-------> MODEM

TX <-------> RX
RX <-------> TX
GND <-------> GND

4 - Open your favourite terminal proggie (such as HyperTerminal), set
the connexion parameters to 9600/8/N/1 and press ENTER...you should
now see the modem's shell prompt. Enter "?" to see a list of commands

5 - You can switch to admin mode with "SET PRIVILEGE ADMIN". The
password is "password" by default. DO NOT ENTER "SET MODEM STOP"
!!!!!!!!!

Regards,

Patrick Saladino, Switzerland

Here's what I got :

MODEM BOOT-UP :
-------------

TeraPro System Boot


Copyright Terayon Corp.





CPU: Milano RU68340
Version: 5.3
BSP version: 1.0/0
Creation date: Aug 9 1999




Press any key to stop auto-boot...
1 0Not SS platform or App version mismatch.
Defaulting to old download procedure...
Copy space flag is not set. Copy space left intact.

auto-booting...

*** set PA atten to 0xff ***
Allocating 5472 bytes memory for power level LUT
checksum is d8 for 200 bytes
Loading EEPROM cal table version 6 for RU 88Mhz RF
checksum is 50 for 178 bytes
Calibration table checksum is OK
SINGLE BOARD MODEM... NO FPGA DOWNLOAD (ff 0)
PHY tasks created
gucBootCopySpaceErased = 1
gucAppCopySpaceErased = 1
update version flag = 0x0
Copy space is available.
RAPP: Reset Event Log
*** I got phyInitReq ***
*** I got msghPhycAsicInit ***

TeraPro > POST: ASIC Revision 0310 detected
POST: BIST passed
POST: Register access test passed
Shift value: 1180
RGSRH: 0003 RGSRL: 0000
RGSRH: 0003 RGSRL: 0000
trgGapCenter iBitPos=17 iShift=12
trgRxTimeBaseShift shift=12 iNewShift=0 iCpcrShift=0000 iNewDelay=0
(old=12)
trgGapCenter RGSRH: 0000 RGSRL: 8000
trgGapCenter iBitPos=15 iShift=-8
trgRxTimeBaseShift shift=-8 iNewShift=8 iCpcrShift=0000 iNewDelay=8
(old=0)
trgGapCenter RGSRH: 0001 RGSRL: 0000
RGSRH: 0001 RGSRL: 0000
Gap is perfectly centered. Done!
POST: Digital loop back test passed
N=13, A=12
M=177, A=14 band=8, c0=0
N=20, A=12
Fr.=339248 N=94, A=42
*** PLL lock self test passed ***
*** I send phyAsicInitResp ***
RAUPP: appConnectDS: appLedState = 0x0
*** I got phyConnectDsReq ***
PHY->DS FREQ = 522368
*** I am in PHYC connect DS ***
*** MINIMUM DS FREQ = 90944 ***
*** DS SCAN AGC THRESHOLD = 0x3500 ***
*** HARDWARE VERSION = 13.54 ***
*** TUNER TYPE = ET-03 ***
*** IF METHOD = Loading passband MFC
PASSBAND ***
*** TX = DDS ***
*** PA = AD8320 ***

*** Starting DS frequency at 522368

*** Found CDMA signal at DS frequency = 522368
Current AGCGR = 0xdc69
*** Clock Recovery ***
trgClockLock: clock locked after N1=1378, N2=350
Clock loop is LOCKED
*** Timebase initialization ***
0x2f9734 (tskPhyCntl): TxCPCR shift value: 00000d80
*** start DS Equalization ***
trNewRuCE() passed
*** Enable Downstream Link ***
*** Completed and sending DS connection resp to APP ***
*** I got phyDsLmsBuff ***
*** Initialize all DS LMS buffers and reset its pointer ***
RAPP->NORMAL: SET MACE TO PROMISCUOUS MODE....
Self sleep mode = 0
RAPP: Adjust Event Log
*** I got phyConnectUsReq ***
*** I am in PHYC connect US ***
*** Setting US Frequency = 21952 ***
*** 204, 188, 164 quarter dB steps in power alignment LUTs ***
Max ranging power = 61 dBmV
My ranging ID is 12cf
*** I got phySetRuID = 2767 ***
*** TXTVLR = 35 dBmV TXCDLR = 68 CHKSUM = 6ff4 ***
*** CHIP_MIM = 66 CHIP_MAX = 70 ***
*** RAN SCAN MODE = 1, CHIP_MIN = 42 CHIP_MAX = 46 CHIP_INCR = 4,
PWR_MIN = 36 dBmV, PWR_MAX = 44 dBmV ***
*** Ranging Passed **
Tx Pwr = 40 dBmV, TxLVLR = 2d4, TxCDLR = 67, TxFDLR = 8, TxFRCR Offset
= 11 (0)
*** Training passed ***
Gear1 = 51.25 dBmV, Gear2 = 51.25 dBmV, Gear3 = 51.25 dBmV
*** I sent connect US resp ***
*** I got phyRuCfgInfoReq and pstPhyCfgInfo = 20c624 ***
**** TRAI = 0 AsicVersion = 784 ***
PRCFF PRCFB
[0] 0060 05a0
[1] 0320 fab0
[2] ff50 ff10
[3] 7ff0 0030
[4] 00b0 fec0
[5] ffe0 0000
[6] 0510 0040
[7] 3500 ff70
Tx Power = 51 dBmV, TxLVLR = 2d4, TxCDLR = 66, TxFDLR = 13, TxFRCR
Offset = 11 (11)
*** I got phySetAsicThresholdInfo ***
&&&&&&&&&&&&&&& LQM is abouRAPP->NORMAL: COMPLETE MODEM LMS POWERUP
RESPONSE
t to start *** I got phySetRuID = &&&&&&&&&&&&&&&&
80 ***
RAPP->NORMAL: MODEM IS AUTHENTICATED
----> AGC Off <----
Starting DS MU measurement...
RAPP->NORMAL: SET MACE TO VIRTUAL MODE....


TeraPro > show lms tat stat

NUMBER OF REQUEST LMS PACKETS RECEIVED .......-> 59
NUMBER OF REQUEST LMS PACKETS DROPPED .......-> 0
NUMBER OF REQUEST LMS MESSAGE RECEIVED .......-> 34
NUMBER OF RESPONSE LMS MESSAGES DROPPED .......-> 0
NUMBER OF RESPONSE LMS PACKETS RECEIVED .......-> 6
NUMBER OF RESPONSE LMS MESSAGES TRANSMITTED .......-> 6
NUMBER OF TASK LMS DMA TIMEOUTS.......-> 0
NUMBER OF DMAC DEVICE ERROR.......-> 0

TeraPro > show modem config
MODEM DOWNSTREAM FREQ SCAN MODE...-> AUTO_SCAN
MODEM MAC ROUTER MODE.............-> VIRTUAL
MODEM MAC ROUTER ADDRESS..........-> 0: 0:77:93:83:bb
MODEM LOOPBACK MODE...............-> OFF
MODEM LINK TYPE...................-> ETHERNET
MODEM CONNECT TYPE................-> 10-BASE-T


TeraPro >

MENUS :
-------
?
Possible commands:

F
READ REG <INT>
RESETF
SET MODEM STOP
SET PHY ACCESS REQ
SET PRIVILEGE [USER|ADMIN]
SHOW ACCESS STAT
SHOW ALARM STATUS
SHOW ISR CNT
SHOW LINK STAT
SHOW LMS STAT
SHOW MODEM CONFIG
SHOW MODEM NV STATUS
SHOW MODEM STATUS
SHOW RAN STAT
SHOW SHELL UTILS
SHOW SYSMON RESET STATE
SHOW TRAIN STAT
SHOW TS STAT
SHOW VERSION
WRITE REG <INT> <INT>
 
R

Remboooo

read reg? write reg?
devil.gif

read reg > zoeken naar 1536 of 1572864 en veranderen in een heeeel hoog getal >:D
 
Status
Niet open voor verdere reacties.
Bovenaan