• Let op: Dit is het archief van het Provider Forum. De berichten die je hier ziet zijn gedateerd en er kan niet meer op worden gereageerd.

Krijg ASUSTOR NAS niet verbonden via FTP

Status
Niet open voor verdere reacties.
C

CoosV

Als ik via filezilla mijn NAS probeer te bereiken op poort 21 krijg ik de volgende meldingen

Status: Adres bepalen van mijnNas.myasustor.com
Status: Verbinden met 83.81.xx.xxx:21...
Status: Verbinding aangemaakt, welkomsbericht afwachten...
Status: TLS initialiseren...
Status: Certificaat controleren....
Status: TLS-verbinding opgezet.
Status: Verbonden
Status: Mappenlijst ophalen...
Status: Server stuurde een passief antwoord met een onbestelbaar adres. Gebruikt het serveradres in de plaats daarvan.
Opdracht: MLSD
Fout: Connection timed out after 20 seconds of inactivity
Fout: Ontvangen van mappenlijst is mislukt

Ik heb op het forum gekeken, maar de antwoorden die daar opstonden waren mij te onduidelijk, daar kon ik niets mee
Intern kan ik wel via FTP verbinding maken, maar ergens zit een blokkade. Ik heb gekeken in de UBEE EVW 3200 modem instellingen, bij geavanceerde instellingen. Onder het onderwerp Gateway, kijk ik bij Options, maar daar staat FTP op enabled, kijk ik bij forwarding en daar ga ik de mist in omdat ik geen idee heb wat daar ingevuld moet worden, maar hier zou m.i. eigenlijk ook niets ingevuld hoeven te worden
Ergens moet poort 21 gezet worden, maar waar? Het gaat fout als de mappenlijst opgehaald moet worden. Ik krijg in het logboek van de NAS echter geen melding
 
Als ik via filezilla mijn NAS probeer te bereiken op poort 21 krijg ik de volgende meldingen

Status: Adres bepalen van mijnNas.myasustor.com
Status: Verbinden met 83.81.xx.xxx:21...
Status: Verbinding aangemaakt, welkomsbericht afwachten...
Status: TLS initialiseren...
Status: Certificaat controleren....
Status: TLS-verbinding opgezet.
Status: Verbonden
Status: Mappenlijst ophalen...
Status: Server stuurde een passief antwoord met een onbestelbaar adres. Gebruikt het serveradres in de plaats daarvan.
Opdracht: MLSD
Fout: Connection timed out after 20 seconds of inactivity
Fout: Ontvangen van mappenlijst is mislukt

Ik heb op het forum gekeken, maar de antwoorden die daar opstonden waren mij te onduidelijk, daar kon ik niets mee
Intern kan ik wel via FTP verbinding maken, maar ergens zit een blokkade. Ik heb gekeken in de UBEE EVW 3200 modem instellingen, bij geavanceerde instellingen. Onder het onderwerp Gateway, kijk ik bij Options, maar daar staat FTP op enabled, kijk ik bij forwarding en daar ga ik de mist in omdat ik geen idee heb wat daar ingevuld moet worden, maar hier zou m.i. eigenlijk ook niets ingevuld hoeven te worden
Ergens moet poort 21 gezet worden, maar waar? Het gaat fout als de mappenlijst opgehaald moet worden. Ik krijg in het logboek van de NAS echter geen melding

Ja, dit klopt.
Ftp kent twee modi: active en passive. De gebruikte modus stel je in in de client, hoewel je dat misschien anders zou verwachten.
Zoek dus in je ftp-programma de optie Passive, vaak een vinkje, en vink deze aan.
Ik kan je eventueel ook de hele theorie uitleggen als je daarin interesse hebt. Maar de oplossing is dat vinkje / optie aan te passen in je client.
 
Op de nas
Passieve poort staat aan, met de optie standaard poortbereik gebruiken (55536-56559).
FTP server staat ingeschakeld op poort 21
Unicode ondersteuning staat op ja
Anoniem inschakelen staat op nee
locale gebruikers zijn aangemaakt,met rechten op div mappen. vanuit mijn eigen pc werkt alles met filezilla, maar extern kun je welverbinding maken, gebruiker en wachtwoord invoeren en daarna gebeurd er niets meer. Ik heb getest of mijn poort openstaat, met https://www.yougetsignal.com/tools/open-ports/ en daar staat de poort open.

In het UBEE modem staat de externe poort op 21 (2x) en de locale poort ook op 21 (2x)
External IP 0.0.0.0
protocol op both
enabled op on

Vanuit mijn eigen pc werkt alles met filezilla, maar extern kun je welverbinding maken, gebruiker en wachtwoord invoeren en daarna gebeurd er niets meer. Ik heb getest of mijn poort openstaat, met https://www.yougetsignal.com/tools/open-ports/ en daar staat de poort open.
Het lijkt er dus op dat op de NAS iets niet goed is maar wat?
 
Bedankt voor je snelle reactie, maar misschien stomme opmerking, hoe doe ik dat?
Moet ik dan een nieuwe regel aanmaken of moet ik de externe start en end poort aanpassen, dit antwoord is me niet helemaal duidelijk.
Zoals je misschien al begrepen hebt is het me intussen gelukt om lokaal wel via filezilla contact te krijgen met de NAS, maar extern lukt het nog steeds niet.
 
Laatst bewerkt door een moderator:
Bedankt voor je snelle reactie, maar misschien stomme opmerking, hoe doe ik dat?
Moet ik dan een nieuwe regel aanmaken of moet ik de externe start en end poort aanpassen, dit antwoord is me niet helemaal duidelijk.
Zoals je misschien al begrepen hebt is het me intussen gelukt om lokaal wel via filezilla contact te krijgen met de NAS, maar extern lukt het nog steeds niet.

Nieuwe regel aanmaken die die poorten doorstuurt. Je moet niet de start- of eindpoort aanpassen, want anders forward je alle poorten vanaf 21 tot 40xxx naar je NAS en dat wil je niet.
Als je ook de startpoort aanpast in het laagste getal, dan forward je juist poort 21 niet meer en die is ook nodig.
Dus twee regels heb je hiervoor nodig in je router.
 
Nieuwe regel aanmaken die die poorten doorstuurt. Je moet niet de start- of eindpoort aanpassen, want anders forward je alle poorten vanaf 21 tot 40xxx naar je NAS en dat wil je niet.
Als je ook de startpoort aanpast in het laagste getal, dan forward je juist poort 21 niet meer en die is ook nodig.
Dus twee regels heb je hiervoor nodig in je router.

Sorry, maar praat je nu over de locale of over de externe start en eind poort.

Dus wat vul ik in--
Ik maak een nieuwe regel met:

Local ip: ip adres van mijn nas
[FONT=&quot]local start port: ??
Local end port: ??
External ip 0.0.0.0
External start port: ???
External end port: [FONT=&quot]???[/FONT]
protocol: Both
[FONT=&quot]Description: [FONT=&quot]--[/FONT][/FONT]
Enabled: on.

[FONT=&quot]Graag nog antwoord op dit detail,dan heb ik he[FONT=&quot]m [FONT=&quot]hopelijk eindelijk [FONT=&quot]online[FONT=&quot].[FONT=&quot]

[/FONT][/FONT][/FONT][/FONT][/FONT][/FONT] [/FONT]
 
Sorry, maar praat je nu over de locale of over de externe start en eind poort.

Om de poorten 55536-56559 te forwarden vul je in:


Local ip: ip adres van je nas
local start port: 55536
Local end port: 56559
External ip 0.0.0.0
External start port: 55536
External end port: 56559
protocol: Both
Description: een beschrijving voor jezelf
Enabled: on.


Start port is dus de eerste poort van een range die geforward moet worden en end-port de laatste.
 
Helaas wederom niks
Wordt extern wel gevraagd om gebruiker en WW, maar daarna verder niks.
Heb alletwee de regels voor de nas ingevuld zoals gezegd,maar blijft hopeloos.
Heb de nas een vast ip adres gegeven, dus daar kan het ook niet aan liggen, en nog gecontroleerd in het modem of dat ook daaraan toegewezen is.
Bij de dchp clients staat wel op dat adres **STATIC IP ADRESS**, maar duration is leeg, staat geen tijdsduur bij wat bij al de andere wel staat.

LAN instellingen van de NAS
Interface: LAN1 (kan geen andere kiezen)
IP adres handmatg instellen aangevinkt
IPv4-adres: 192.168. enz
subnetmasker: 255.255.255.0
Gateway: 192.168.enz
MTU: 1500
 
Laatst bewerkt door een moderator:
Je zegt dat je de Filezilla als client gebruikt. Op een netwerk buiten je eigen netwerk neem ik aan ? Kun je op die machine poort 20 openzetten ? Dan zou je active FTP kunnen gebruiken ...
Vaak werkt active FTP zelfs zonder poort 20 open te zetten, de router herkent dan het FTP protocol, en doet dat dan voor je.
 
Status
Niet open voor verdere reacties.
Terug
Bovenaan