Cisco newbie

W

woodapple

Zojuist heb ik een cisco 1700 router ontvangen. Netjes het mac adres van mijn chello netwerkkaart opgeschreven maar denk je dat ik ergens gevonden krijg hoe je dat moet instellen op zo'n cisco router? Helaas een simpele draytek 2200 heeft het er standaard inzitten maar in mijn cisco 1700 krijg ik het niet terug gevonden.
Kan iemand me hiermee helpen ?? Of me naar een site of handleiding doorverwiijzen ?? :-[ ???
 

Meeuw

Forum Gebruiker
Berichten
2.497
je kan ook je ip adres vrij geven met je originele netwerkkaart en je dan opnieuw aanmelden via provisioning
 
F

Fatass

connect met het ding via n seriele kabel ofzo

enable
<password>
conf t
int <interface> // FastEthernet0 ofzo
mac-address <mac-adres> // ab12.bc34.56ef, deze notatie
exit
exit
wr

Maar je kan natuurlijk ook het mac-adres van de cisco registreren:
zet dhcp aan:

enable
<password>
conf t
int <interface>
ip address dhcp
exit
exit

Kijk vervolgens of je n 10.?.?.? adres hebt ofzo.

sh ip interface

Zo ja, dan kan je nu met de pc naar de provisioningpagina en daar het macadres van de cisco registreren.
 
Topicstarter
Topicstarter
W

woodapple

Bedankt, ik zie inderdaad dat ik een ip heb gekregen via de interface status. Nu kan er alleen nog niks naar buiten of naar binnen. Zijn daar nog simpele commando's voor ?
 
F

Fatass

Ik weet niet precies wat je allemaal ingestelt hebt, maar je moet in ieder geval voor NAT aangeven wat de lokale en internet interface is.

enable
<password>
conf t
int <internetinterface>
description Internet
ip nat outside
exit
int <lokaleinterface>
description Lokaal
ip nat inside
exit
ip cef // hiermee zet je kort gezegd hardwarematige routing aan. Dit is uiteraard sneller, maar maakt debuggen en sommige geavanceerde functies moeilijker of onmogelijk.
exit
wr


Verder is het misschien handig om te weten dat standaard telnet open staat op de internet interface. Dit is uiteraard niet optimaal. Zelf block ik alle poorten onder 1024:

enable
<password>
conf t
access-list 100 deny tcp any any lt 1024 //block alle tcp poorten onder 1024
//access-list 100 deny tcp any any eq telnet //als je enkel telnet wilt blocken
access-list 100 permit ip any any //laat verder al het ip verkeer door
int <internetinterface>
ip access-group 100 in //hang accesslist 100 (die we zojuist gemaakt hebben) aan de internet interface en pas deze toe op inkomende pakketjes.
exit
exit
wr
 
Topicstarter
Topicstarter
W

woodapple

MM helaas dat ding heeft ook nog zoiets als een VLAN die geconfigureerd staan ?? en standaard staat er een flinke firewall aan met allemaal inbound en outbound regels ?? Nog meer tips ?? Firewall bijvoorbeeld uit dat ik systematisch kan beginnen met het opbouwen daarvan??
 
F

Fatass

Misschien is het handig om de config hier eens neer te zetten Vergeet niet de wachtwoorden en evt internet ip adressen eruit te halen!!
Ik kan niet zeggen dat ik n Cisco expert ben, maar misschien kan ik er wat mee :)
En je zou inderdaad ook met n schone config kunnen beginnen.
 
Topicstarter
Topicstarter
W

woodapple

Hierbij dan de config.

yourname#show running-config
Building configuration...

Current configuration : 2505 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
username cisco privilege 15 password 0 xxxx (ons wachtwoord)
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
ip domain name yourdomain.com
!
!
ip cef
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
!
no crypto isakmp enable
!
bridge irb
!
!
interface BRI0
no ip address
shutdown
no cdp enable
!
interface FastEthernet0
description Internet
mac-address xxxx.xxxx.xxxx (ons mac adres)
ip address dhcp
ip nat outside
duplex auto
speed auto
no cdp enable
!
interface FastEthernet1
no ip address
no cdp enable
!
interface FastEthernet2
no ip address
no cdp enable
!
interface FastEthernet3
no ip address
no cdp enable
!
interface FastEthernet4
no ip address
no cdp enable
!
interface Vlan1
description Lokaal
ip address 192.168.1.251 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
!
ip default-gateway 62.XXX.XX.XXX (hier staat ons kloppend chello IP, dus dat wwerkt  ;D)
ip classless
ip http server
ip http authentication local
ip http secure-server
!
!
!
no cdp run
!
!
control-plane
!
banner login ^C
-----------------------------------------------------------------------
Cisco Security Device Manager (CSDM) is installed on this device.
This feature requires the one time use, initial credentials,
of username "cisco" with password "cisco".

Please use these credentials to login into the router if you do not wish
to use CSDM to configure the device.

WARNING: PLEASE CHANGE OR REMOVE THESE INITIAL CREDENTIALS IF YOU DO NOT
PLAN TO USE CSDM. LEAVING THEM UNCHANGED MAY LEAD TO THE DEVICE BEING
VULNERABLE TO UNAUTHORIZED ACCESS.

You can remove these initial credentials after entering enable and
issuing the following CLI command:

no username cisco

NOTE: If you remove the initial credentials, you will NOT be able to
use CSDM until you configure a new user name.

For more information about CSDM please follow the instructions in the
QUICK START GUIDE for your router or at
https://www.cisco.com/en/US/products/
sw/secursw/ps5318/products_qanda_item09186a00801a14cc.shtml
-----------------------------------------------------------------------
^C
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
!
end

yourname#
 
F

Fatass

ip default-gateway 62.XXX.XX.XXX (hier staat ons kloppend chello IP, dus dat wwerkt Grin)

Anders dan de naam doet vermoeden is dit de default-gateway voor het management verkeer en NIET voor verkeer door de router heen.
Doe in enable mode:

sh ip route

en kijk of je n regel als de volgende er tussen hebt:

S* 0.0.0.0/0 [254/0] via 80.57.20.1

Waarom staat er eigenlijk n Vlan geconfigureerd?
Als er geen VLANs gebruikt worden zou ik hem weghalen
in config mode:
no int Vlan1
en daarna een van de ethernetinterfaces als lokale interface ocnfigureren.
Vergeet niet de instellingen op te slaan als alles werkt met wr :)
 
Bovenaan