[Apache2] Win2k werkt niet

Status
Niet open voor verdere reacties.
G

GT

Ik heb net Apache2 geinstalleerd op m'n server hierzo.

Lokaal werkt hij goed.

Ik heb op mijn router port 80 geforward naar mijn server maar iemand anders hem via internet wil benaderen kan hij de server niet vinden.

Pingen gaat wel goed.

Ook telnetten naar een andere pc in mijn lokale netwerk gaat goed.

Weet iemand misschien wat ik hier aan kan doen?
 
R

Remboooo

Een poort forwarden is op een of andere vage manier niet hetzelfde als een virtual server. Je moet es kijken of je een virtual server voor poort 80 kunt aanmaken op je router.
 
Topicstarter
Topicstarter
G

GT

Remboooo zei:
Een poort forwarden is op een of andere vage manier niet hetzelfde als een virtual server. Je moet es kijken of je een virtual server voor poort 80 kunt aanmaken op je router.

Ik heb het probleem gevonden.

Chello heeft de poorten 80 & 21 geblocked misschien nog meer maar dat weet ik niet.

Port 2000 werkt nl wel goed.

En een paar weken terug werkte het allemaal nog wel met mijn server.
 
D

DutchBlood

Poort 1337 is koel.
En die is vaak niet geblokkerd dus...
 
D

DutchBlood

Geen idee, maar hij is gewoon koel.

Maar ff de conclusie:
Als je een server runt gebruik dus dan niet de poorten 80 en 21.
 

bouke

Forum Gebruiker
Berichten
157
Ik heb een tijdje Apache gedraait op m'n pc met ip-adres 192.168.0.3 op poort 80. Portforwarding had ik van 8080 ext naar 80 int geconfigureerd.

Verkeer verliep dus als volgt:

212.187.32.186:8080 -> 192.168.0.3:80

en

192.168.0.3:80 -> 212.187.32.186:8080

Op deze manier draait de server op poort 8080, maar lokaal gewoon op poort 80 (simpel doch doeltreffend).

[edit]

Ik zie zo-nu-en-dan nog pogingen in m'n firewall-log... maar helaas er loopt geen httpd meer via dit ip-adres. Forwarding is disabled.

[/edit]
 
R

Remboooo

je kunt bij apache ook gewoon instellen dat hij op poort 8080 (of welke poort dan ook) runt ::)
 
Topicstarter
Topicstarter
G

GT

Remboooo zei:
je kunt bij apache ook gewoon instellen dat hij op poort 8080 (of welke poort dan ook) runt ::)

Yep dat is zonder meer waar. Maar het handigste blijft als mensen https://www.domein intypen en niet https://www.domein:1337 ofzo :)

Ik heb nu maar poort 81 genomen das wel makkelijk te onthouden.

Port 21 is btw niet geblocked zoals ik eerder vermelde!
 
R

Remboooo

het handigste blijft als mensen https://www.domein intypen en niet https://www.domein:1337 ofzo

Als je de poort door je router laat forwarden naar 8080, dan moeten mensen toch nog steeds https://www.domein:8080 intypen? Of denk ik nou krom?
 
Status
Niet open voor verdere reacties.
Bovenaan